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1
Introduction
This document provides you with information required for configuring the 
Dell™ PowerVault™ NX1950 storage system as a cluster solution and offers 
troubleshooting tips. The PowerVault NX1950 cluster solution enables two 
PowerVault NX1950 nodes to provide highly-available system and data. 
Dell supports the following configuration of the PowerVault NX1950 cluster 
solution:

• Integrated solution—This solution consists of two PowerVault NX1950 
storage systems configured with a Dell PowerVault MD3000 storage array.

• Gateway solution—This solution consists of up to eight PowerVault NX1950 
storage systems configured with Dell|EMC storage arrays.

 NOTE: Throughout this document, PowerVault NX1950 storage system refers to 
the individual cluster node. PowerVault NX1950 cluster solution refers to the 
configuration of two or more PowerVault NX1950 storage systems running 
Microsoft® Cluster Services (MSCS) attached to either PowerVault MD3000 storage 
array or a Dell|EMC storage array.

Overview of MSCS
A cluster is a collection of servers that work together to provide highly- available 
resources. Examples of resources include services, IP addresses, network 
names, and disk drives. The PowerVault NX1950 cluster solution uses MSCS 
and the Dell Storage Initialization Wizard to configure the solution for 
clustering. The Dell customized components help the user to integrate the 
solution with the services provided by the operating system in a seamless 
way to configure the system.

Microsoft Windows® Unified Data Storage Server 2003 provides two 
technologies for cluster solutions through MSCS—Server Cluster and 
Network Load Balancing (NLB). The PowerVault NX1950 cluster solution 
does not support NLB. This guide focuses on the Server Cluster technology 
provided by the operating system.
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The following list includes basic features of MSCS:

• Highly-available and server consolidation

• Deployable on a single network

• Multiple-node cluster support

 NOTE: The multiple-node cluster is supported on PowerVault NX1950 cluster 
solution with Windows Unified Data Storage Server 2003, Enterprise x64 
Edition operating system only.

For more information about MSCS features and functionality, see the 
Microsoft Support website at support.microsoft.com.

Nodes
Nodes or cluster nodes refer to the PowerVault NX1950 storage systems that 
are members of the cluster. The PowerVault NX1950 storage solution supports 
a multiple-node cluster.

Cluster Resources
The cluster resources are physical or logical entities with the following 
characteristics:

• Can be brought online/offline

• Can be managed within a cluster

• Can be hosted by one node within the cluster

Examples of resources are Network Name, IP addresses, services, applications, 
and disk storage. During cluster failover, only the cluster resources failover to 
another node.

The PowerVault NX1950 cluster solution supports cluster resources and you 
can use the cluster administration tools to configure them. For more 
information about cluster administration tools, see "Cluster Administration 
and Management" on page 12.

Resource Group
A resource group is a group of resources (IP addresses, disk storage) that can 
failover as a unit. An example of a resource group is a Highly-Available Server 
Instance.
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Quorum Resource
MSCS uses quorum resource to maintain state and configuration information of 
the individual nodes and to enforce cluster unity. The quorum-device resource 
stores critical information about the cluster nodes and the resources in the 
cluster to ensure and manage consistency across both nodes. There are two types 
of quorum resources namely: quorum-device and majority-of-nodes cluster.

The quorum-device resource requires a storage class device that is accessible 
by the other node in the cluster. The quorum-device resource is typically a 
physical disk. The PowerVault NX1950 cluster solution uses a quorum-device 
that is located on the storage array.

For information about how to create or select a quorum resource, see 
"Assigning the Quorum Disk to the Cluster" on page 31.

Shared Versus Private Storage
The PowerVault NX1950 cluster solution supports two types of storage—
Shared and Private. When you use Shared storage, each node within the 
cluster has access to all storage resources. When you use Private storage, only 
the individual node has access to the assigned storage resource. To enable the 
PowerVault NX1950 configuration as a cluster, the quorum disk must be 
deployed on a shared storage disk. The PowerVault NX1950 cluster solution is 
deployed as a Shared storage solution by default to ensure that the quorum 
disk can be created and mapped to both the nodes in the cluster.

The PowerVault NX1950 cluster solution supports both Private and Shared storage 
for the logical unit numbers (LUNs) created after the quorum disk is created.

 NOTICE: In the Integrated solution, you can use the Provision Storage Wizard to 
configure Shared storage only. For more information, see "Limitations While 
Creating a Shared LUN" on page 41.

Firewall Port Exceptions
The PowerVault NX1950 cluster solution is pre-configured from Dell with 
Windows Firewall enabled. The port and application exceptions are 
configured for deployment, management, and use of the cluster solution. 
No user intervention is required to enable exceptions for clustering support.

 NOTE: A Windows Firewall Exception is a Microsoft term used to denote ports or 
applications that are allowed access through the firewall. 
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If the Windows Firewall settings are restored to the default values either due 
to user action or because of a system restore, you must reset the firewall port 
exceptions for the cluster setup to be successful. Dell provides a batch file 
that sets the required port exceptions to deploy, manage, and use the 
PowerVault NX1950 cluster solution. For instructions to download and execute 
the batch file, see the Dell PowerVault NX1950 Systems Deployment Guide.

 NOTICE: Ensure that you perform the procedure described in the 
Dell PowerVault NX1950 Systems Deployment Guide to avoid system failure.

Configuration Tools
The following tools assist in the configuration of the storage array and the 
Dell PowerVault NX1950 storage systems and enable them to operate as a 
cluster.

• The Dell Storage Initialization Wizard communicates with the storage 
array and ensures that set up is complete.

• The Microsoft Windows Unified Data Storage Server 2003, Enterprise x64 
Edition provides the following:

– The PowerVault NX1950 Initial Configuration Tasks wizard — This 
wizard helps you to configure the PowerVault NX1950 storage system 
to be a part of the cluster.

– For cluster administration and troubleshooting, the operating system 
provides a graphical user interface (GUI) tool — Cluster 
Administrator (also referred to as Cluadmin.exe) and a command 
line interface (CLI) tool — cluster.exe. For more information about 
these tools, see "Cluster Administration and Management" on 
page 11.

– Microsoft Cluster Setup tools — The Windows Unified Data Storage 
Server 2003, Enterprise x64 Edition provides cluster configuration and 
management tools for advanced users. The features of these tools are 
beyond the scope of this document. For more information about these 
features and functionality, see the Microsoft Support website at 
support.microsoft.com.
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Supported Operating System
The PowerVault NX1950 cluster solution supports the Windows Unified Data 
Storage Server 2003, Enterprise x64 Edition operating system.

 NOTE: The Microsoft Windows Unified Data Storage Server 2003, Standard x64 
Edition is supported on the PowerVault NX1950 storage system as a stand-alone 
solution only. You can purchase an upgrade kit from Dell to upgrade to the Windows 
Unified Data Storage Server 2003, Enterprise x64 Edition.

For more information about the upgrade procedure, see the 
Dell PowerVault NX1950 Systems Upgrading Your Operating System document 
located on the Dell Support website at support.dell.com. 

Cluster Administration and Management
The Windows Unified Data Storage Server 2003, Enterprise x64 Edition 
provides cluster administration through Cluster Administrator (also referred 
to as Cluadmin.exe)—a GUI tool and cluster.exe—a CLI tool.

Cluster Administrator
Cluster Administrator allows administrators to manage cluster objects, 
establish groups, initiate failover, handle maintenance, and monitor cluster 
activity through a convenient graphical interface.

Follow one of these procedures to access the Cluster Administrator:

• Go to Start→ Administrative Tools→ Cluster Administrator.

• Type cluadmin at the MS-DOS® prompt.

• Access the tool from the PowerVault NX1950 Management Console.

For more information about Cluster Administrator, see the Microsoft Support 
website at support.microsoft.com.

Cluster.exe
The CLI tool for cluster administration is called cluster.exe and can be 
accessed from the MS-DOS prompt. For more information on the CLI 
commands for this tool, type cluster /? at the MS-DOS prompt or see 
the Microsoft Support website at support.microsoft.com.
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Other Documents You May Need
You can refer to the following documents located on the Dell Support website 
at support.dell.com. See the:

• Dell PowerVault NX1950 Systems Hardware Owner’s Manual for physical, 
firmware, software interface features, and troubleshooting for your 
PowerVault NX1950 storage system.

• Dell PowerVault NX1950 Systems Getting Started Guide for system 
features, installation, and configuration of your PowerVault NX1950 
storage system.

• Dell PowerVault NX1950 Systems Deployment Guide for configuration 
procedures on your system and a general overview of the Windows Unified 
Data Storage Server 2003 operating systems.

• Dell PowerVault NX1950 Systems Installation Guide for deployment, 
cabling, configuring, and localizing your PowerVault NX1950 storage 
solution.

• Dell PowerVault NX1950 Systems Important Information for known issues.

• Dell PowerVault NX1950 Systems Upgrading Your Operating System for 
instructions to upgrade your operating system.

• Dell PowerVault NX1950 Systems Support Matrix for supported hardware, 
software, and configurations.

• Dell PowerVault NX1950 Systems End-to-End Deployment Guide for iSCSI.
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2
Setting Up Your Cluster
This section provides information about the prerequisites and the procedure 
to set up your Dell™ PowerVault™ NX1950 cluster solution.

 NOTE: For known issues and fixes regarding configuring and managing your 
cluster, see "Important Information" on page 39.

Configuring Your Cluster
The PowerVault NX1950 cluster solution provides the following wizards to 
ensure that the solution is configured appropriately:

• The Dell Storage Initialization Wizard — automates all storage 
communication required for the PowerVault NX1950 Initial 
Configuration Tasks wizard to communicate with the array.

• The PowerVault NX1950 Initial Configuration Tasks wizard — walks 
you through the steps necessary to perform configuration tasks like 
deploying the PowerVault NX1950 cluster solution.

• The Microsoft Management Console for Storage — is a utility for all 
storage-related activities.

 NOTE: Throughout this document and in the GUI, Microsoft® Management 
Console for Storage and PowerVault NX1950 Management Console are 
synonymous.

It is recommended that you follow the sequence of steps in Table 2-1 to 
successfully create a cluster.
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* While the DSIW is running, be sure to select the Clustered option on both servers when prompted.

 NOTICE: Before setting up the cluster, ensure that all the cluster nodes complete 
step 3. If you do not perform step 3 on all the cluster nodes, one of them may not be 
added to the cluster.

Table 2-1.  Steps to Create the Cluster Solution

Step/Phase Recommended Sequence

Node 1 Node 2-8 Storage Array/
Network

1 Cable the solution 1 2 3

2 Turn on 5 6 4
NOTE: This 
step may take a 
few minutes to 
complete.

3 Initial setup

• Setup and Verify Domain Controller Server

• Setup and Verify Domain Name Server

• Setup and Verify Network Connectivity

• Setup and Verify Node Passwords

• Change Region Information

• Adjust Time & Date

• Run the Dell Storage Initialization 
Wizard (DSIW)*

7 8

4 Use the PowerVault NX1950 Initial 
Configuration Tasks wizard to create a 
cluster

9

5 Add the remaining node(s) 10

6 Join cluster 11

7 Configure Highly-Available Server Instance 
(optional)

12
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Before setting up a cluster, you must complete several initial tasks of 
connecting to the array, naming the array, and setting up the preliminary 
items. For more information regarding the initial tasks to perform, see 
"Prerequisites for Cabling Your Cluster" on page 15.

Prerequisites for Cabling Your Cluster
You must set up at least two LAN connections to enable your storage solution as a 
cluster. The PowerVault NX1950 cluster solution uses one or more 
connections for client access (public) IP addresses and a dedicated 
connection for heartbeat (private) network. Ensure that the heartbeat 
connection is configured on a separate subnet.

Figure 2-1. PowerVault NX1950 Management Console

 NOTE: You must set up two static IP addresses on two different subnets for the 
cluster—one for the private (heartbeat) network and one for the client access 
(public) network.
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Cabling Your Integrated Solution
Figure 2-2 shows the supported cable configuration for the 
PowerVault NX1950 cluster solution.

You must connect the SAS 5/E Adapters on both the PowerVault NX1950 
storage systems to the PowerVault MD3000 storage array to enable the 
storage systems as cluster nodes. For your Ethernet port connection, It 
is recommended that you use the on-board connections for the public 
network. These on-board NIC connections support TCP/IP Offload Engine 
(TOE). If available, dedicate one optional NIC port for the MSCS heartbeat 
connection; otherwise you must dedicate one on-board connection for the 
MSCS heartbeat.

Figure 2-2. Example of Cabling a PowerVault NX1950 Integrated Cluster Solution 

1

2

3
4

7

8

PowerVault NX1950 storage system 0

PowerVault MD3000 storage array6

5

PowerVault NX1950 storage system 1

controller 1controller 0
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Cabling Your Gateway Solution
Figure 2-3 shows the PowerVault NX1950 Gateway cluster solution. You must 
connect the Qlogic Adapters on both the PowerVault NX1950 storage systems 
to the Dell|EMC storage arrays to enable the storage systems as cluster 
nodes. For your Ethernet port connection, it is recommended that you use 
the on-board connections for the public network. These on-board NIC 
connections support TOE. If available, dedicate one optional NIC port for 
the MSCS heartbeat connection; otherwise you must dedicate one on-board 
connection for the MSCS heartbeat.

1 NIC port A to Gb Ethernet switch 
(optional) for MSCS heartbeat

5 Port 1 on PowerVault NX1950 storage 
system 1 SAS HBA to In-1 on controller 1

2 NIC port B to Gb Ethernet switch 
(optional) 

6 Port 0 on PowerVault NX1950 storage 
system 1 SAS HBA to In-1 on controller 0

3 On-board Gb1 and Gb2 to Gb 
Ethernet switch(es)

7 Port 0 on PowerVault NX1950 storage 
system 0 SAS HBA to In-0 on controller 0

4 Port 1 on PowerVault NX1950 
storage system 0 SAS HBA to 
In-0 on controller 1

8 DRAC port to Ethernet switch for lights-out 
management (optional)
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Figure 2-3. Example of Cabling a PowerVault NX1950 Gateway Cluster Solution 

PowerVault NX1950 Initial Configuration 
Tasks Wizard
It is recommended that you use the PowerVault NX1950 Initial 
Configuration Tasks wizard to configure the PowerVault NX1950 storage 
system and to access MSCS. Figure 2-4 illustrates the wizard. The 
PowerVault NX1950 Initial Configuration Tasks wizard helps you to perform 
various tasks to configure the resources required by a cluster. 

Before setting up the cluster, you must perform step 1 to step 4 in Table 2-1.

 NOTE: The Customize this system section in the wizard is specific to cluster setup. 
The PowerVault NX1950 cluster solution is supported only with the Microsoft® 

Windows® Unified Data Storage Server 2003, Enterprise x64 Edition. 

1 NIC port A to Gb Ethernet switch 
(optional) for MSCS heartbeat

4 Port 2 on HBA to SAN

2 NIC port B to Gb Ethernet switch 
(optional)

5 Port 1 on HBA to SAN

3 On-board Gb1 and Gb2 to Gigabit 
Ethernet switch(es)

6 DRAC port to Ethernet switch for 
lights-out management 

1 2

6 35 4

PowerVault NX1950 storage system
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Figure 2-4. PowerVault NX1950 Initial Configuration Tasks

 NOTE: You can also access the PowerVault NX1950 Initial Configuration Tasks 
wizard from the PowerVault NX1950 Management Console. To launch this wizard, 
click Edit server configuration located in the right pane of the window as 
highlighted in the Figure 2-1 below.

Creating the Cluster
The PowerVault NX1950 Initial Configuration Tasks wizard can be used to 
create the cluster. Table 2-2 summarizes the steps for creating a cluster using 
this wizard.

Table 2-2. Phases in Creating a Cluster

Step/Phase Node 1 Nodes 2-8

Start Cluster Configuration wizard ✓

Create the Quorum Disk ✓

Checking for Existing Cluster 
Configuration

✓

Set the Cluster IP address ✓
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 NOTE: You can initiate the "Create or Join Cluster" from any node. The node that 
you create the quorum resource in; is referred to as node 1.

Perform the following procedure to create a cluster:

1 Go to the PowerVault NX1950 Storage Tasks wizard.

2 In the Customize this System section, click Create or Join Cluster.

This launches the Cluster Configuration wizard.

3 If a quorum resource is not configured already, the Cluster Configuration 
wizard creates the quorum disk. If the quorum disk creation fails, see the 
"Troubleshooting" on page 35 to correct the issue.

Figure 2-5. Quorum Creation

Supply Administrative Information ✓

Verify Configuration ✓

Start Creation Process ✓

Verify Completion ✓

Add remaining nodes ✓

Join Cluster ✓

Configure Highly-Available File Server 
Instance (optional)

✓

✓ indicates that the step is applicable to the respective cluster component.

Table 2-2. Phases in Creating a Cluster (continued)

Step/Phase Node 1 Nodes 2-8
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4 After the quorum disk is created, the New Server Cluster Wizard appears. 
This wizard takes you though the process of cluster creation. Click Next to 
begin the process.

5 The Analyzing Configuration window appears and the system 
configuration is analyzed. If a cluster configuration already exists, this step 
fails. For information about correcting this error, see "Troubleshooting" on 
page 35.

If no error is reported after the analysis is completed, click Next.

 NOTE: The New Server Cluster Wizard may caution you about the cluster 
configuration due to the Microsoft Windows Firewall exception being enabled. 
This does not impact successful cluster setup. For more information about 
Firewall port exceptions, see "Firewall Port Exceptions" on page 9.

6 The IP Address window prompts you to enter the IP address. Enter the IP 
address that you want to configure for the cluster and click Next.

 NOTE: This IP address is used for the cluster management (public) 
connection. 

7 The Cluster Service Account window appears. Enter the domain 
controller administrative account information and click Next.

 NOTE: It is recommended that you create a domain account with limited 
privileges for this purpose. This domain account is granted with local 
administrator rights on each node and can be used for Controlling Services.

8 The Proposed Cluster Configuration window appears. This window gives 
you a summary of the configuration that is being created.

a Before you proceed to the next screen, click Quorum to select the 
correct quorum disk. The Cluster Configuration Quorum screen 
appears.

b Select a quorum disk (shared quorum disk) that is accessible to both 
the nodes. This is essential for a successful cluster creation.

9 After selecting the quorum disk, check for errors in the summary.

If there are errors, click Back to go to the incorrect section and correct the 
error. If no errors are reported, click Next to proceed to the next screen.

10 The Creating the Cluster screen appears. This dialog box gives you the 
progress of the cluster creation process and the warnings that might have 
occurred during the process as shown in Figure 2-6.
Setting Up Your Cluster 21



Figure 2-6. New Server Cluster Wizard

 NOTE: The cautions in the Creating the Cluster window in Figure 2-6 are 
reported as a result of the firewall being enabled. This does not impact 
successful cluster creation. For more information about firewall port 
exceptions, see "Firewall Port Exceptions" on page 9.

11 The cluster creation process is complete. If any errors have occurred during the 
cluster creation, the color of the progress bar appears red. Click Next.

12 The Completing the New Server Cluster Wizard screen appears. 
Click Finish.

 NOTE: This wizard gives you an option to add additional nodes to the cluster. 
The PowerVault NX1950 cluster solution supports only two nodes with the 
PowerVault MD3000 storage array (Integrated Solution) and up to eight nodes 
with the Dell|EMC storage arrays (Gateway Solution).

After the node(s) are added, complete the on-screen instructions.

13 Click Create or Join Cluster in the PowerVault NX1950 Initial 
Configuration Tasks wizard. In the remaining cluster nodes, start the 
PowerVault NX1950 Initial Configuration Tasks wizard, and click Create 
or Join Cluster.
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14 The Welcome to the Add Nodes screen appears. Click Next to continue.

15 The Cluster Name and Domain screen appears. Enter the cluster name 
and domain of the cluster that you want to join and click Next.

16 The Select Computers screen appears. This dialog box allows you to add 
additional nodes to the cluster. Perform the steps below to choose and 
configure the additional node(s):

a In the Select Computers screen, click Browse and locate the 
additional node(s).

b After selecting the additional node(s), click Advanced.

 NOTE: Microsoft recommends that you follow this procedure to add 
new node(s). The process of adding new node(s) may fail if you do not 
perform this procedure.

c Select the Advanced (minimum) configuration option and then click 
Next. The analysis phase begins.

d If the wizard reports any issues during analysis, go to the 
corresponding section and fix the error. If no error is reported and the 
analysis is complete, click Next.

 NOTE: The Analyzing Configuration screen may display caution 
messages. These appear as the Windows Firewall is enabled and do 
not impact successful cluster creation.

17 The Cluster Service Account appears. Enter the administrator’s user name 
and password. If you do not have this information, contact your system 
administrator.

18 The Proposed Cluster Configuration screen appears. This screen displays 
a summary of configuration. Review the configuration. If any 
configuration items are incorrect, click Back and change the items. If the 
configuration is correct, click Next to begin adding the node.

19 The Adding Nodes to the Cluster screen appears. This screen displays the 
status of adding the node to the cluster.
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20 If the node is successfully added, the progress bar is green. If there are any 
errors, the progress bar is red. Click Back to fix any configuration errors 
that caused the failure. After the errors are corrected and the progress bar 
is green, click Next.

21 The Completing the Add Nodes Wizard screen appears indicating that 
the second node has been added successfully. You can view the log of 
events by clicking View Log.... 

22 Click Finish to complete the process. You can use the Cluster 
Administrator tool to verify that the node has been added successfully.

 NOTE: Repeat step 13 to step 22 for each additional node.
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3
Managing Your Cluster

Creating a Highly Available File Server Instance
In the Dell™ PowerVault™ NX1950 cluster solution, all cluster nodes must 
be configured with a Highly-Available File Server Instance to access the 
resources of the cluster. This creates a cluster resource group that includes a 
network name and IP address allowing the file shares that are provisioned on 
the Highly-Available Server Instance to failover between nodes.

To create a Highly-Available Server Instance, follow the procedure below:

1 Go to the PowerVault NX1950 Management Console and launch the 
PowerVault NX1950 Initial Configuration Tasks wizard.

2 Click File Server Management (Local).

3 In the Actions pane, click Edit Server Configuration to start the 
creation wizard.

4 In the Customize this system section, click Create a highly available file 
server instance.

5 After the Highly available file server instance wizard launches, enter the 
name, IP address, and the Subnet mask for the IP address and then 
click OK. The process of creating a highly-available server instance begins 
and a progress bar indicates the status of this process.

 NOTE: When you create a Highly-Available Server Instance on a cluster node 
using the PowerVault NX1950 Initial Configuration Tasks wizard, the status of the 
Highly-Available Server Instance is not visible to the other nodes within the cluster. 
This behavior is expected and is behaving as designed. To access the Highly- 
Available Server Instance, each node in the cluster must have ownership of 
the instance.

After this process is complete, all nodes have access to the cluster 
resource group.

 NOTE: To set up Snapshots for iSCSI Targets, see the Dell PowerVault NX1950 
Systems End-to-End Deployment Guide for iSCSI on the Dell Support website at 
support.dell.com.
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Creating a Highly Available iSCSI Target Using Microsoft iSCSI Target 3.0
1 Click Start→ Administrative Tools→ Services→ Microsoft iSCSI Software 

Target→ (right-click) Stop, to stop the iSCSI service.

2 Stop the Microsoft® iSCSI service on each cluster node and set it to Manual.

3 On the Active node, go to Start→ Administrative Tools→ Cluster 
Administrator→ Groups→ Cluster Group (right-click)→ New Resource.

4 Enter the following required information and click Next:

– Name
– Description
– Resource Type: Select Generic Service
– Group: Select Cluster Group

5 Verify that all cluster nodes are in the Possible Owners window and click 
Next.

6 Select the following dependencies, click Add, and then click Next:

– Cluster IP Address

– Cluster Name

– Physical Disk of Choice

 NOTE: Do not select quorum disk.

7 In the Service Name field, type WinTarget, and then click Next.

8 When prompted for the registry key, click Add, type 
Software\Microsoft\iSCSI Target, and then click Finish.

9 Right-click on Resource and select Online.

10 On the active node, go to PowerVault NX1950 Management Console→ 
Microsoft iSCSI Software Target→ Devices.

11 Select the physical disk that you chose in step 6. Right-click on the disk 
and complete the wizard steps to create a LUN.

12 Right-click Microsoft iSCSI Software Target and then click Create New 
Target.

13 Right-click the new Target and add the existing LUN that you created in 
step 11.

 NOTE: If you are migrating from Microsoft Target 3.0 to Microsoft Target 3.1, see 
the Dell PowerVault NX1950 Systems Solution Upgrade Guide.
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Creating a Highly Available iSCSI Server Instance Using 
Microsoft iSCSI Target 3.1
To create Targets and assign the .vhd files, the following steps need to be 
performed:

Create Highly Available iSCSI Instance

1 Right-click the Microsoft iSCSI Software Target icon in the Microsoft 
Management Console (MMC) and click Create high availability instance 
for iSCSI.

2 Type the desired name into the field for Resource Group Name and click Add. 
Fill out the rest of the required fields

– IP Address

– Subnet mask

– Network Interface

3 Click OK twice.

The highly-available instance for iSCSI should be created successfully.

Create Target

Initiator Side

• If you are not using iSNS server, go to the host/initiator to add the newly 
created Target’s iSCSI highly-available IP address in the Target portals for 
connectivity.

• Click Advanced and select the following options:

– Local Adapter—Microsoft iSCSI Initiator

– Source IP—Microsoft iSCSI Initiator

– IP address of the client for iSCSI traffic

• If you are using iSNS server, then right-click the iSCSI Target icon in 
MMC, select Properties, go to iSNS tab and add iSNS IP address. Go to 
initiator and add iSNS IP address in the Discovery tab.
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Target Side

1 Right-click the Target icon in the MMC and click Create iSCSI Target.

2 Type the Target name, Target description, and click Next.

3 Browse for the desired IQN identifier of the initiator or click Advanced→ 
Add IP address and enter the IP address of the initiator, and then click Next.

4 Select the desired Highly-Available iSCSI instance from the drop-down 
menu and click Next.

5 Click Finish.  

The Target should be successfully created.

Create VDs for the iSCSI Target

 NOTE: Prior to creating a VD for the iSCSI Target, you need to create a volume 
using the Storage Provision wizard.

Right-click the newly created Target and select Create Virtual disk for iSCSI 
Target. Follow the wizard to successfully create a VD.

Move Volume to desired iSCSI Instance

1 Launch Cluster Administrator by clicking Start→ Administrative Tools→ 
Cluster Administrator. Locate the volume that the devices (.vhd files) 
were located on. This is under cluster groups.

2 Right-click the volume, select Change Groups and select one of the newly 
created highly-available instances you want to move the volume to.

3 A pop-up screen is displayed for confirmation. Click Yes twice.

Import Devices

1 Right-click the devices icon in the MMC, select Import Virtual Disk, and 
click Next.

2 Browse to the volume the .vhd files are located on, select the .vhd file, click 
OK, Next, and then Finish.

3 Repeat step 2 to import all .vhd files.
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Virtual Disk/Target Associations

1 Right-click the Target and select Add existing virtual disk.

2 Select the desired virtual disk and click OK.

The virtual disk is associated to the Target and ready for use.

Creating a Shared Storage Disk
1 Click Start→ Administrative Tools→ Windows unified Data Storage 

Server PowerVault NX1950 Management Console→ Share and Storage 
Management→ Run Provision Storage.

2 Follow the on-screen instructions. When you are prompted to select server 
assignment, select the default selection (All servers in this cluster).

Complete the configuration steps in the wizard. Shared storage disk is created 
successfully.

 NOTE: For information about limitations in setting up a Shared storage disk, see the 
"Limitations While Creating a Shared LUN" on page 41.

Creating a File Share on a Highly Available File Server Instance

1 Go to PowerVault NX1950 Management Console→ Share and Storage 
Management→ Run Provision Share.

2 Select the disk that you want to create a file share on, click Next, and verify 
that the desired instance appears.

3 Complete the on-screen instructions to complete the creation of a file 
share on a Highly-Available Server Instance.

Adding a Node Manually
If a node is not available during the initial creation of the cluster, you have to 
run the Add Node wizard and add it manually to the cluster. In this scenario, 
running through the Add Node wizard does not complete all the items 
required for the cluster to function properly. You have to complete the 
remaining tasks that are listed in Table 3-1.
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You must perform the actions in the table on each additional node for the 
cluster to function properly. These steps assume that the Add Node wizard 
has been run on the new node and the node is now ready to complete the 
configuration setup.

Server Connections

After the cluster setup is complete, perform the following procedure to 
update the server connections to reflect the cluster configuration.

1 Click Start→ Administrative Tools→ Windows Unified Data Storage 
Server→ Share and Storage Manager→ Storage Manager for SANs→ 
LUN Management to start the PowerVault NX1950 management console.

2 In the LUN Management section, click Manage Server Connections.

3 The Manage Server Connections window appears. Click Manage Clusters 
to add the cluster to the managed server connections.

4 In the Manage Clusters window, click Add.

5 Enter the name of the cluster and verify that the server is a local server. 
Click OK.

The cluster appears in the list of managed server connections.

Table 3-1. Adding a Node Manually

Step/Phase New Node(s) Existing Node(s)

1 Add the cluster to the Server Connections ✓ ✓

2 Edit the Cluster Connection to include all nodes ✓ ✓

3 Assign the Quorum Disk to the Cluster ✓ ✓

4 Configure the RPC Locator Service as Automatic 
and start the service

✓ ✓

✓ indicates that the step is applicable to the respective cluster component.
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Adding an Additional Node

After the cluster has been added to the server connections, the additional 
node must also be added to the list of server connections.

1 If you have already done so, click Manage Server Connections in the 
management console.

2 The Manage Server Connections window appears. Click Add.

3 The Add Server window appears. Click Browse.

4 In the Select Computer window, click Find Now, and enter the 
administrator user name and password. Click OK.

The Select Computer window displays the available nodes.

5 Select the node that you want to add to the cluster and click OK.

6 In the Manage Server Connections window, click Manage clusters.

7 Select the cluster and then click Edit.

8 The Edit Cluster window appears. The server that you have added appears 
in the bottom pane of the window.

9 Select the server by selecting the check box beside it and then click OK.

Assigning the Quorum Disk to the Cluster

The next phase of manually adding the device is to assign the quorum disk to 
the cluster. In order to perform this step:

1 Go to Share and Storage Manager→ Storage Manager for SANs→ 
LUN Management.

2 The management console appears. In the right pane of the console, select 
Assign LUN... in the Selected LUN section.

3 The Assign LUN Wizard launches the Server Access window.

4 Ensure that the Assign the LUN now option is selected and click Next.

5 Click OK to confirm the assignment of the logical unit number (LUN) to 
the cluster.

6 After the assignment is complete, go to the management console and assign 
the quorum LUN server to the cluster from the LUN Management view.
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Configure the RPC Locator Service

The last step in creating your cluster is to set the RPC Locator Service to 
Automatic. Perform the procedure below to change this setting:

1 Click Start→ Programs→ Administrative Tools→ Services.

2 Locate the RPC Locator Service and double-click the icon.

3 The Remote Procedure Call (RPC) Locator Properties window launches. 
In the General tab, set the Startup type as Automatic.

4 Click Start to start the service.

 NOTE: MSCS uses the RPC Locator Service for remote management purposes. 
If this service is not configured, MSCS does not behave as expected.

After these steps are completed on all servers, the cluster configuration can be 
tested. For more information on testing the cluster configuration, see the 
Microsoft Windows Unified Data Storage Server 2003 Help.

Removing Nodes From the Cluster
 NOTICE: Few actions described in this section are termed as destructive cluster 

operations. Ensure that you back up all data on the cluster nodes before performing 
these actions to avoid loss of data.

Removing a Node
You can use the Cluster Administrator or cluster.exe to remove a node from 
the cluster. To remove the node from the cluster using the Cluster 
Administrator, perform the following procedure:

1 In Cluster Administrator tool, open the cluster connection by selecting 
File→ Open Connection.

2 If the cluster name is not provided, click Browse and select the cluster name.

3 After you select the cluster, the Cluster Administrator lists the cluster and 
all the member nodes. From the list of member nodes, select the one that 
is to be removed.

4 Right-click on the name of the node and then click Stop the Cluster 
Service on the Node.

5 After the node has been selected, click File→ Evict Node. This removes 
the node from the cluster.
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To remove the cluster node using the cluster.exe tool, you must stop the cluster 
service and then evict the node by performing the following procedure:

1 Open an MS-DOS® prompt.

2 Enter the following commands: 

cluster node <node name> /stop

cluster node <node name> /evict

3 After executing these commands, enter the following command to ensure 
that the node has been removed:

cluster node <node name> /status

It is recommended that you verify that the node has been removed by 
checking from another node in the cluster.

Removing the Last Node
Removing the last node in the cluster is different than removing other nodes 
in the cluster. Removing the last node removes the cluster.

To remove the last node using Cluster Administrator, stop the Cluster Service 
on the node, and then click File→Evict Node.

To remove the last node, using the cluster.exe tool, enter the following 
commands:

cluster node <node name> /stop

cluster node <node name> /forcecleanup 

 NOTICE: If this operation fails, the PowerVault NX1950 cluster solution does not 
function properly. Exercise extreme caution in planning the cluster so that removal 
of the last node is not necessary.

Replacing a Node
To replace a node, you must remove the node and then add a node manually.

For instructions about removing a node, see "Removing Nodes From the 
Cluster" on page 32. For instructions about adding a node manually, see 
"Adding a Node Manually" on page 29.
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Removing the Cluster
Removing the cluster is a destructive operation and may affect cluster 
functionality.

 NOTICE: Ensure that you back up all data on the cluster nodes before performing 
these actions to avoid loss of data.

To remove cluster, remove all but one node and then remove the last node 
using the /forcecleanup option. After the last node has been removed, 
the cluster has been removed. To clear the history of the cluster:

1 Go to Storage Manager for SANs→Manage Clusters→Edit Cluster.

2 Deselect all the nodes.

3 Click OK and then click Remove to delete the cluster entry.
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A
Troubleshooting
Microsoft® Windows® Unified Data Storage Server 2003 provides general 
cluster troubleshooting. To access this Help and Support content:

1 Click Start→ Help and Support.

2 The Help and Support window appears. Search for content related to 
Cluster Troubleshooting.

In the search results, locate and select the Troubleshooting: Server Cluster 
option. This section gives you information about general cluster 
troubleshooting.

This section contains common issues you may encounter on your 
Dell™ PowerVault™ NX1950 cluster solution.

Table A-1. General Cluster Troubleshooting

Problem Area Probable Cause Corrective Action

Network 
Communication

The nodes cannot 
access the storage 
system, or the cluster 
software is not 
functioning with the 
storage system.

The storage system is not 
cabled properly to the 
nodes or the cabling 
between the storage 
components is incorrect.

Ensure that all external 
cables are securely attached 
to the external connectors on 
your system. For an example 
of supported cabling 
configuration, see "Other 
Documents You May Need" 
on page 13.

One of the cables or 
connectors is faulty.

Ensure that the cables or 
connectors are not damaged.

The TCP/IP 
configuration is 
incorrect.

Ensure that the cluster nodes 
are on the same subnet to 
prevent network 
communication errors.

IP addresses not 
configured correctly.

The cluster heartbeat IP 
address should be on a 
different subnet than the 
cluster IP address.
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Firewall exceptions are 
closed.

Execute the firewall 
exceptions script that is a 
part of the PowerVault 
NX1950 cluster solution 
software. This script restores 
the exceptions to factory 
settings and allows cluster 
operations to run.

The PowerVault 
NX1950 cluster 
solution is unable to 
detect the PowerVault 
MD3000 storage array

The PowerVault NX1950 
cluster nodes and the 
PowerVault MD3000 
storage array were not 
turned on in the correct 
sequence.

To correct this issue:
1 Turn off the cluster nodes 

and the PowerVault 
MD3000 storage array.

2 Turn on the PowerVault 
MD3000 storage array and 
allow it to initialize (The 
blue LED on the front 
panel of the PowerVault 
MD3000 storage array 
must glow).

3 After the PowerVault 
MD3000 storage array has 
initialized, turn on the 
PowerVault NX1950 cluster 
nodes.

The PowerVault MD3000 
storage array is now 
detectable.

Replacing the 
PowerVault MD3000 
storage array

For instructions on replacing 
the storage array, see the 
documentation that shipped 
with the PowerVault 
MD3000 storage array.

Table A-1. General Cluster Troubleshooting (continued)

Problem Area Probable Cause Corrective Action
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Replacing the SAS 5/E 
host bus adapter (HBA)

To replace the HBA, perform 
the following steps:

1 Turn off the cluster node 
and remove the cabling.

2 Replace the HBA.
3 Cable and turn on the 

cluster node.
4 Exit from the Dell 

Storage Initialization 
Wizard when it attempts 
to run and launch the Dell 
Modular Disk Storage 
Manager.

5 Select Manual Discovery 
and type in local host.

6 Click Resolve topology 
conflict and follow the 
recommended steps to 
resolve the conflict.

Unable to access newly 
created volume from 
Windows Explorer.

LUN was created from 
another node in the 
cluster.

Log off and log on again.

The Dell Storage 
Initialization Wizard 
does not register 
additional cluster nodes 
to the PowerVault 
MD3000 storage array.

A dummy host may be 
configured to the 
PowerVault MD3000 
storage array.

For information about fixing 
the error, see "Dell Storage 
Initialization Wizard Does 
Not Register the Cluster 
Node to the 
PowerVault MD3000 Storage 
Array if a Dummy Host is 
Registered" on page 42.

Table A-1. General Cluster Troubleshooting (continued)

Problem Area Probable Cause Corrective Action
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B
Important Information
This section provides important information about Dell™ PowerVault™ NX1950 
cluster solution. The following topics are discussed:

• "Deleting LUNs With Storage Manager for SANs" on page 39

• "Dell Storage Initialization Wizard and Array Name" on page 40

• "If a Node is Configured With iSCSI LUNs Before Joining the Cluster, 
the iSCSI Target MMC Snap-in Crashes" on page 40

• "Connection to the iSCSI LUN is Lost When a Cluster Failover Occurs" 
on page 40

• "Limitations While Creating a Shared LUN" on page 41

• "Dell Storage Initialization Wizard Does Not Register the Cluster Node 
to the PowerVault MD3000 Storage Array if a Dummy Host is Registered" 
on page 42

• "Assigning LUNs/Volumes to a Cluster via Storage Manager for SANs" on 
page 42

Deleting LUNs With Storage Manager for SANs
When you are deleting logical unit numbers (LUNs) using Storage Manager for 
SANs in the Integrated Solution with the PowerVault MD3000 storage array, you 
cannot remove the reservation for disks that are within the cluster. To work 
around this issue perform one of the following procedures:

• Use the PowerVault NX1950 Management Console for Storage.

– Go to PowerVault NX1950 Management Console→ Share and 
Storage Management.

– Stop the sharing of the LUN.

– Select the LUN that is not be shared and remove it.

– Delete the LUN using the PowerVault NX1950 Management 

This is the preferred method for deleting LUNs associated with the cluster.

Console’s Storage Manager for SANs utility.
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• Use the Cluster Administrator to delete the LUN. Start the Cluster 
Administrator and then change the disk associated with the cluster to offline.

 NOTE: This action reports an error message from the PowerVault NX1950 
Management Console, but the LUN has been deleted.

Dell Storage Initialization Wizard and 
Array Name
The Dell Storage Initialization Wizard in the Integrated Solution with the 
PowerVault MD3000 storage array configures the cluster nodes and the 
storage array for the PowerVault NX1950 cluster solution. When you are 
configuring the cluster, ensure that the array name is persistent across both 
nodes. If the array name is changed on one node and the change is not 
replicated across the second node, the node without the change encounters 
Virtual Disk Service (VDS) provider issues.

If a Node is Configured With iSCSI LUNs Before 
Joining the Cluster, the iSCSI Target MMC 
Snap-in Crashes
If iSCSI LUNs are configured on your PowerVault NX1950 storage system and 
you are upgrading the operating system from Microsoft® Windows® Unified 
Data Storage Server 2003 Standard Edition to Windows Unified Data 
Storage Server 2003 Enterprise Edition, you must follow the procedure 
described in the Dell PowerVault NX1950 Systems Important Information 
Guide located on the Dell Support website at support.dell.com.

Connection to the iSCSI LUN is Lost When a 
Cluster Failover Occurs
If the Microsoft iSCSI Software Initiator is not configured properly, the 
network settings for the Microsoft iSCSI Target may be reset when a resource 
group fails. To re-establish connection to the iSCSI LUN, follow the 
procedure described in the Dell PowerVault NX1950 Systems Important 
Information Guide located on the Dell Support website at support.dell.com.
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Limitations While Creating a Shared LUN
In the Integrated Solution with the PowerVault MD3000 storage array, you 
can use the Provision Storage Wizard to create LUNs. In the 
Server Assignment window, you will be prompted to assign the LUN by 
choosing one of the options below as shown in Figure B-1.

• This server only

• All servers in this cluster

• Other server or cluster

Select the default option All servers in this cluster and follow the instructions 
on the screen to create the LUN.

Figure B-1. Provision Storage Wizard

 NOTICE: Selecting This Server Only option in the Server Assignment window of the 
Provision Storage Wizard when creating a LUN assigns the LUN to the cluster. You can 
create a private LUN manually only using the Dell PowerVault Modular Disk Storage 
Manager. For more information see the Dell PowerVault Modular Disk Storage Manager 
User's Guide.
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Dell Storage Initialization Wizard Does Not 
Register the Cluster Node to the 
PowerVault MD3000 Storage Array if a Dummy 
Host is Registered
You can register a maximum of two hosts (or cluster nodes) with the 
PowerVault MD3000 storage array using the Dell Storage Initialization Wizard. 
The wizard does not register additional hosts after two hosts have been 
registered. You may encounter an error condition where you are not allowed to 
register an additional host even when a single physical host is registered. If you 
encounter this error, verify to ensure that a dummy host is not registered.

 NOTE: A dummy host is created either when a host is renamed or when an existing 
host is turned off. This host is not operational but it is visible to the storage array. 
You can delete the dummy host from the storage array using the Dell PowerVault 
Modular Disk Storage Manager.

Assigning LUNs/Volumes to a Cluster via Storage 
Manager for SANs
The Assign function in Storage Manager for SANs only exposes the 
LUN/Volumes to the hosts and does not assign it to the cluster group. 
To assign the LUN/volume to a cluster group, perform the following steps:

1 Assign the LUN to the cluster.

2 Verify that the LUN has been assigned to the Host Group in PowerVault 
Modular Disk Storage Manager.

3 In Disk Management, verify that the disk is basic and assign it a drive letter.

4 Launch Cluster Administration by clicking Start→ Administrative Tools→ 
Cluster Administrator→ Groups. Right-click Cluster Group and select 
New Resource.

5 Enter the following required information:

– Name

– Description

– Resource Type: Select Physical Disk

– Group: Select Cluster Group
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6 Click Next.

7 Verify that all cluster nodes are listed in the Possible Owners window and 
click Next.

8 Select the following dependencies: 

– Cluster IP Address

– Cluster Name

– Physical Disk of Choice

9 Click Add and then click Next.

10 Follow the instructions on the screen and then click Finish.

11 Right-click on Resource and select Online.  The disk is now part of the cluster.

12 Refresh the Volumes tab under Share and Storage Management.
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Glossary
CD
Compact Disk

Cluster
A configuration of two Dell™ PowerVault™ NX1950 storage systems and Storage 
Array that uses MSCS.

DRAC
Dell Remote Assistance Card

GB
Gigabyte

Gb
Gigabit

HD
Hard Drive

Host Group
A group of two or more hosts that share access to specific virtual disks on the 
storage array. All hosts in a host group must be running the same operating system.

iSCSI
Internet Small Computer System Interface

LUN
Logical Unit Number

MSCS
Microsoft® Cluster Services

NAS
Network Attached Storage
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NAS Solution
A configuration that consists of at least one PowerVault NX1950 storage system 
with a PowerVault MD3000 storage array connected via SAS and Ethernet.

NIC
Network Interface Card

Node
A PowerVault NX1950 storage system that can be a member of a cluster 
configuration.

PCI
Peripheral Component Interface

PERC 5/i
PowerEdge Raid Controller (Internal)

RAM
Random Access Memory

SAN
Storage Area Network

SAS
Serial Attached SCSI

SAS 5/E
Dell Host Bus Adapter for Serial Attached SCSI

VDS
Virtual Disk Service

VSS
Volume Shadow Copy Service
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